This is an example configuration showing how to forward the ports necessary to make Blizzard's World of Warcraft Updater work properly with a Cisco IOS based NAT firewall. The World of Warcraft Community Site has more information regarding which ports need to be forwarded and why. Please note that any word-wrapping is a matter of formatting and will not occur when pasted directly to your router.

In this example, the host running the Updater application has an IP address of 192.168.9.10.

!
interface FastEthernet0/0
 ip address 192.168.9.1 255.255.255.0
 ip nat inside
!
interface FastEthernet0/1
 ip address dhcp
 ip nat outside
!
ip nat inside source list 1 interface FastEthernet0/1 overload
ip nat inside source static tcp 192.168.9.10 3724 interface FastEthernet0/1 3724
ip nat inside source static tcp 192.168.9.10 6881 interface FastEthernet0/1 6881
ip nat inside source static tcp 192.168.9.10 6882 interface FastEthernet0/1 6882
ip nat inside source static tcp 192.168.9.10 6883 interface FastEthernet0/1 6883
ip nat inside source static tcp 192.168.9.10 6884 interface FastEthernet0/1 6884
ip nat inside source static tcp 192.168.9.10 6885 interface FastEthernet0/1 6885
ip nat inside source static tcp 192.168.9.10 6886 interface FastEthernet0/1 6886
ip nat inside source static tcp 192.168.9.10 6887 interface FastEthernet0/1 6887
ip nat inside source static tcp 192.168.9.10 6888 interface FastEthernet0/1 6888
ip nat inside source static tcp 192.168.9.10 6889 interface FastEthernet0/1 6889
ip nat inside source static tcp 192.168.9.10 6890 interface FastEthernet0/1 6890
ip nat inside source static tcp 192.168.9.10 6891 interface FastEthernet0/1 6891
ip nat inside source static tcp 192.168.9.10 6892 interface FastEthernet0/1 6892
ip nat inside source static tcp 192.168.9.10 6893 interface FastEthernet0/1 6893
ip nat inside source static tcp 192.168.9.10 6894 interface FastEthernet0/1 6894
ip nat inside source static tcp 192.168.9.10 6895 interface FastEthernet0/1 6895
ip nat inside source static tcp 192.168.9.10 6896 interface FastEthernet0/1 6896
ip nat inside source static tcp 192.168.9.10 6897 interface FastEthernet0/1 6897
ip nat inside source static tcp 192.168.9.10 6898 interface FastEthernet0/1 6898
ip nat inside source static tcp 192.168.9.10 6899 interface FastEthernet0/1 6899
ip nat inside source static tcp 192.168.9.10 6900 interface FastEthernet0/1 6900
ip nat inside source static tcp 192.168.9.10 6901 interface FastEthernet0/1 6901
ip nat inside source static tcp 192.168.9.10 6902 interface FastEthernet0/1 6902
ip nat inside source static tcp 192.168.9.10 6903 interface FastEthernet0/1 6903
ip nat inside source static tcp 192.168.9.10 6904 interface FastEthernet0/1 6904
ip nat inside source static tcp 192.168.9.10 6905 interface FastEthernet0/1 6905
ip nat inside source static tcp 192.168.9.10 6906 interface FastEthernet0/1 6906
ip nat inside source static tcp 192.168.9.10 6907 interface FastEthernet0/1 6907
ip nat inside source static tcp 192.168.9.10 6908 interface FastEthernet0/1 6908
ip nat inside source static tcp 192.168.9.10 6909 interface FastEthernet0/1 6909
ip nat inside source static tcp 192.168.9.10 6910 interface FastEthernet0/1 6910
ip nat inside source static tcp 192.168.9.10 6911 interface FastEthernet0/1 6911
ip nat inside source static tcp 192.168.9.10 6912 interface FastEthernet0/1 6912
ip nat inside source static tcp 192.168.9.10 6913 interface FastEthernet0/1 6913
ip nat inside source static tcp 192.168.9.10 6914 interface FastEthernet0/1 6914
ip nat inside source static tcp 192.168.9.10 6915 interface FastEthernet0/1 6915
ip nat inside source static tcp 192.168.9.10 6916 interface FastEthernet0/1 6916
ip nat inside source static tcp 192.168.9.10 6917 interface FastEthernet0/1 6917
ip nat inside source static tcp 192.168.9.10 6918 interface FastEthernet0/1 6918
ip nat inside source static tcp 192.168.9.10 6919 interface FastEthernet0/1 6919
ip nat inside source static tcp 192.168.9.10 6920 interface FastEthernet0/1 6920
ip nat inside source static tcp 192.168.9.10 6921 interface FastEthernet0/1 6921
ip nat inside source static tcp 192.168.9.10 6922 interface FastEthernet0/1 6922
ip nat inside source static tcp 192.168.9.10 6923 interface FastEthernet0/1 6923
ip nat inside source static tcp 192.168.9.10 6924 interface FastEthernet0/1 6924
ip nat inside source static tcp 192.168.9.10 6925 interface FastEthernet0/1 6925
ip nat inside source static tcp 192.168.9.10 6926 interface FastEthernet0/1 6926
ip nat inside source static tcp 192.168.9.10 6927 interface FastEthernet0/1 6927
ip nat inside source static tcp 192.168.9.10 6928 interface FastEthernet0/1 6928
ip nat inside source static tcp 192.168.9.10 6929 interface FastEthernet0/1 6929
ip nat inside source static tcp 192.168.9.10 6930 interface FastEthernet0/1 6930
ip nat inside source static tcp 192.168.9.10 6931 interface FastEthernet0/1 6931
ip nat inside source static tcp 192.168.9.10 6932 interface FastEthernet0/1 6932
ip nat inside source static tcp 192.168.9.10 6933 interface FastEthernet0/1 6933
ip nat inside source static tcp 192.168.9.10 6934 interface FastEthernet0/1 6934
ip nat inside source static tcp 192.168.9.10 6935 interface FastEthernet0/1 6935
ip nat inside source static tcp 192.168.9.10 6936 interface FastEthernet0/1 6936
ip nat inside source static tcp 192.168.9.10 6937 interface FastEthernet0/1 6937
ip nat inside source static tcp 192.168.9.10 6938 interface FastEthernet0/1 6938
ip nat inside source static tcp 192.168.9.10 6939 interface FastEthernet0/1 6939
ip nat inside source static tcp 192.168.9.10 6940 interface FastEthernet0/1 6940
ip nat inside source static tcp 192.168.9.10 6941 interface FastEthernet0/1 6941
ip nat inside source static tcp 192.168.9.10 6942 interface FastEthernet0/1 6942
ip nat inside source static tcp 192.168.9.10 6943 interface FastEthernet0/1 6943
ip nat inside source static tcp 192.168.9.10 6944 interface FastEthernet0/1 6944
ip nat inside source static tcp 192.168.9.10 6945 interface FastEthernet0/1 6945
ip nat inside source static tcp 192.168.9.10 6946 interface FastEthernet0/1 6946
ip nat inside source static tcp 192.168.9.10 6947 interface FastEthernet0/1 6947
ip nat inside source static tcp 192.168.9.10 6948 interface FastEthernet0/1 6948
ip nat inside source static tcp 192.168.9.10 6949 interface FastEthernet0/1 6949
ip nat inside source static tcp 192.168.9.10 6950 interface FastEthernet0/1 6950
ip nat inside source static tcp 192.168.9.10 6951 interface FastEthernet0/1 6951
ip nat inside source static tcp 192.168.9.10 6952 interface FastEthernet0/1 6952
ip nat inside source static tcp 192.168.9.10 6953 interface FastEthernet0/1 6953
ip nat inside source static tcp 192.168.9.10 6954 interface FastEthernet0/1 6954
ip nat inside source static tcp 192.168.9.10 6955 interface FastEthernet0/1 6955
ip nat inside source static tcp 192.168.9.10 6956 interface FastEthernet0/1 6956
ip nat inside source static tcp 192.168.9.10 6957 interface FastEthernet0/1 6957
ip nat inside source static tcp 192.168.9.10 6958 interface FastEthernet0/1 6958
ip nat inside source static tcp 192.168.9.10 6959 interface FastEthernet0/1 6959
ip nat inside source static tcp 192.168.9.10 6960 interface FastEthernet0/1 6960
ip nat inside source static tcp 192.168.9.10 6961 interface FastEthernet0/1 6961
ip nat inside source static tcp 192.168.9.10 6962 interface FastEthernet0/1 6962
ip nat inside source static tcp 192.168.9.10 6963 interface FastEthernet0/1 6963
ip nat inside source static tcp 192.168.9.10 6964 interface FastEthernet0/1 6964
ip nat inside source static tcp 192.168.9.10 6965 interface FastEthernet0/1 6965
ip nat inside source static tcp 192.168.9.10 6966 interface FastEthernet0/1 6966
ip nat inside source static tcp 192.168.9.10 6967 interface FastEthernet0/1 6967
ip nat inside source static tcp 192.168.9.10 6968 interface FastEthernet0/1 6968
ip nat inside source static tcp 192.168.9.10 6969 interface FastEthernet0/1 6969
ip nat inside source static tcp 192.168.9.10 6970 interface FastEthernet0/1 6970
ip nat inside source static tcp 192.168.9.10 6971 interface FastEthernet0/1 6971
ip nat inside source static tcp 192.168.9.10 6972 interface FastEthernet0/1 6972
ip nat inside source static tcp 192.168.9.10 6973 interface FastEthernet0/1 6973
ip nat inside source static tcp 192.168.9.10 6974 interface FastEthernet0/1 6974
ip nat inside source static tcp 192.168.9.10 6975 interface FastEthernet0/1 6975
ip nat inside source static tcp 192.168.9.10 6976 interface FastEthernet0/1 6976
ip nat inside source static tcp 192.168.9.10 6977 interface FastEthernet0/1 6977
ip nat inside source static tcp 192.168.9.10 6978 interface FastEthernet0/1 6978
ip nat inside source static tcp 192.168.9.10 6979 interface FastEthernet0/1 6979
ip nat inside source static tcp 192.168.9.10 6980 interface FastEthernet0/1 6980
ip nat inside source static tcp 192.168.9.10 6981 interface FastEthernet0/1 6981
ip nat inside source static tcp 192.168.9.10 6982 interface FastEthernet0/1 6982
ip nat inside source static tcp 192.168.9.10 6983 interface FastEthernet0/1 6983
ip nat inside source static tcp 192.168.9.10 6984 interface FastEthernet0/1 6984
ip nat inside source static tcp 192.168.9.10 6985 interface FastEthernet0/1 6985
ip nat inside source static tcp 192.168.9.10 6986 interface FastEthernet0/1 6986
ip nat inside source static tcp 192.168.9.10 6987 interface FastEthernet0/1 6987
ip nat inside source static tcp 192.168.9.10 6988 interface FastEthernet0/1 6988
ip nat inside source static tcp 192.168.9.10 6989 interface FastEthernet0/1 6989
ip nat inside source static tcp 192.168.9.10 6990 interface FastEthernet0/1 6990
ip nat inside source static tcp 192.168.9.10 6991 interface FastEthernet0/1 6991
ip nat inside source static tcp 192.168.9.10 6992 interface FastEthernet0/1 6992
ip nat inside source static tcp 192.168.9.10 6993 interface FastEthernet0/1 6993
ip nat inside source static tcp 192.168.9.10 6994 interface FastEthernet0/1 6994
ip nat inside source static tcp 192.168.9.10 6995 interface FastEthernet0/1 6995
ip nat inside source static tcp 192.168.9.10 6996 interface FastEthernet0/1 6996
ip nat inside source static tcp 192.168.9.10 6997 interface FastEthernet0/1 6997
ip nat inside source static tcp 192.168.9.10 6998 interface FastEthernet0/1 6998
ip nat inside source static tcp 192.168.9.10 6999 interface FastEthernet0/1 6999
!
access-list 1 permit 192.168.9.0 0.0.0.255
!
Interested in learning more about network and system administration? Subscribe to Slaptijack today for free.