The situation: A Cisco 7604 with SAMI card is able to send packets from the individual IOS instances running on the SAMI PPCs, but is unable to receive packets.

The hardware: The table below describes the hardware involved.

Part Number Description
CISCO7604 Cisco 7604 Router
SUP32-GE-3B Cisco Catalyst 6500 Series / Cisco 7600 Series Supervisor Engine 32 with 8 ports Gigabit Ethernet, PFC3B, and MSFC2A
WS-SVC-SAMI-BB-K9 Cisco Service and Application Module for IP

The software: The Sup32 is running 12.2(33)SRD4 and the SAMI PPCs are running 12.4(24)YG2.

The workaround: I've called this section the workaround, because I'm certain this isn't the solution. I'm fairly confident that something in my configuration has caused this situation to occur.

What I've discovered is that, although the Sup32 has dynamically learned the mac-address of the SAMI PPC, it isn't associating that mac-address with a port. For example,

SLAP#show mac-address-table vlan 44
Legend: * - primary entry
        age - seconds since last seen
        n/a - not available

  vlan   mac address     type    learn     age              ports
------+----------------+--------+-----+----------+--------------------------
Active Supervisor:
*   44  xxxx.xxxx.xxxx   dynamic  Yes         15

Therefore, when packets are incoming for the SAMI PPC mac-address, the Sup32 does not know how to handle them. I would assume it would broadcast the packets out all ports associated with the VLAN, but that doesn't seem to be the case. Clearing the dynamic entries out of the mac-address-table seems to fix the problem, but it means the Sup32 is unable to communicate with the SAMI PPCs.

To make everyone happy, I added static entries into the mac-address-table:

mac-address-table static xxxx.xxxx.xxxx vlan 44 interface TenGigabitEthernet3/1

This has had the effect of allowing the Sup32 to communicate with the SAMI PPC directly rather than simply passing packets along.

Note: I know this can not be working as intended. I'm certain that either a) I have something wrong with my configuration, or b) I'm not using the 7600 + SAMI as it was intended.