XQuartz LogoI always forget to do this. Long ago I installed XQuartz on my Mac OS X 10.5 (Leopard) desktop. For the life of me, I can't remember why I installed it. XQuartz replaces the X11 that comes with Mac OS X. I might have done this since XQuartz is more up to date than Apple's X11. Another possibility is that one of the two X11 apps I use frequently (Gimp or Wireshark) required the update. The reason doesn't really matter, the important thing is to remember to reinstall XQuartz after every Apple Software Update.

If you're experiencing this problem, you might see something like the following in your log files:

org.x.startx[5001] Xquartz: bootstrap_look_up(): Unknown service name 
org.x.startx[5001] giving up. 
org.x.startx[5001] /usr/X11/bin/xinit:  Operation timed out (errno 60):  unable to connect to X server 
org.x.startx[5001] /usr/X11/bin/xinit:  No such process (errno 3):  Server error. 
org.x.startx[5164] font_cache: Scanning user font directories to generate X11 font caches 
org.x.startx[5164] font_cache: Updating FC cache 
org.x.privileged_startx[1606] font_cache: Scanning system font directories to generate X11 font caches 
defaults[5191] 
The domain/default pair of (org.x.X11, dpi) does not exist
org.x.startx[5164] xauth:  creating new authority file /Users/scott/.serverauth.5164 
org.x.startx[5164] Xquartz: X11.app = /Applications/Utilities/X11.app/Contents/MacOS/X11 
org.x.startx[5164] Xquartz: Starting X server: /Applications/Utilities/X11.app/Contents/MacOS/X11 --listenonly 
org.x.startx[5164] dyld: Library not loaded: /usr/X11/lib/libpixman-1.0.dylib 
org.x.startx[5164]   Referenced from: /Applications/Utilities/X11.app/Contents/MacOS/X11.bin 
org.x.startx[5164]   Reason: Incompatible library version: X11.bin requires version 15.0.0 or later, but libpixman-1.0.dylib provides version 13.0.0 
org.x.privileged_startx[1606] font_cache: Updating FC cache 
org.x.startx[5164] font_cache: Done 
org.x.startx[5164] waiting for X server to begin accepting connections

By the way, Snow Leopard users are not affected by this problem.